Unable to SSH git clone

Hi! I recently started with using SSH instead of username/password auth in the bash console when using GIT. However, I am having problems. Here's what I have done:

  • Got the python anywhere custom plan -> ssh enabled
  • created ~/.ssh
  • created known hosts there and added bitbucket's public key
  • run a ssh-keygen and added my public key to bitbucket
  • pasted the git clone command

and yet my temrinal says

git clone                                                                                                                 
Cloning into 'stl_to_print'...                                                                                                                                                       
ssh: connect to host port 22: Network is unreachable                                                                                                                   
fatal: Could not read from remote repository.

Please make sure you have the correct access rights                                                                                                                                  
and the repository exists.

even if I run


i get

ssh: connect to host port 22: Network is unreachable

Does anyone know how to resolve this?

Was the console you run it in created before you upgraded to paid account?

Probably yes, but I restarted the page and re-logged at least a thousand times. Got it sorted out now, for some reason the console didn't have interned access (i checked ping I used a different console and it worked first try. It was very unintuitive, as I never even considered that problem, because I was communicating with the console in my browser, using internet. Strange. Is that expected behavior? Shouldn't there be somewhere a disclaimer that spares users from this experience?

We present that information to the users on upgrade. Do you see any other places where you would expect it?