Disk quota exceeded when installing Dash + Pandas + Scipy

I'm new to pythonanywhere and am really excited to try it out using the beginners account. Unfortunately, I'm running into the following issue:

To run my dash app I need dash.html components that don't come with the pre-installed dash version. Additionally, I need functionality from the Pandas, Numpy and Scipy packages. When I try installing these however, I'm running into a "Disk quota exceeded" error.

Is there any way to test the functionality of my code on pythonanywhere without getting a hacker's account?

Pandas, Numpy and Scipy are pre-installed on PythonAnywhere (you can check all pre-installed Python packages here).

Regarding dash -- have you tried to install those missing components? Or do you require a different version of dash? In both cases you should be able to install the required package.

Thanks for the reply!

I require a new version of dash and was able to install it in a virtual environment. However, when trying my code in the virtual environment, I get the following error message:

2022-07-13 12:51:37,256: Error running WSGI application 2022-07-13 12:51:37,257: ModuleNotFoundError: No module named 'pandas' 2022-07-13 12:51:37,257: File "/var/www/", line 7, in <module> 2022-07-13 12:51:37,258: from app import app as application 2022-07-13 12:51:37,258: 2022-07-13 12:51:37,258: File "/home/betterbat/mysite/", line 2, in <module> 2022-07-13 12:51:37,258: import pandas 2022-07-13 12:51:37,258: ********* 2022-07-13 12:51:37,259: If you're seeing an import error and don't know why, 2022-07-13 12:51:37,259: we have a dedicated help page to help you debug: 2022-07-13 12:51:37,259:

Here's my WSGI file.

import sys

path = '/home/betterbat/mysite' if path not in sys.path: sys.path.append(path)

from app import app as application

And my code (MRE).

import dash import pandas

app = Dash(name)

app.layout = html.Div([ html.H1("Test") ])

Do you know what the issue could be?

If you're creating a virtual env, pandas would not be there by default. You'd need either to install it or to create the venv with --system-site-packages option so it picks up pre-installed packages.

Thanks, that worked!

Excellent, thanks for confirming!